SMF 2.0 Bugs

Discussion in 'Forum Business & Announcements' started by Rudy, Mar 14, 2010.

  1. Rudy

    Rudy ♪♫♪♫♫♪♪♫♪♪ Staff Member

    Location:
    Home
    This MAY be fixed in 2.0 RC3 (released last week), but Craig found a bug and I just duplicated it here.


    If you compose a private message with apostrophes, they will get preceded by a backslash when you go to preview them. If you preview the message a second time, a second backslash is inserted. So...


    First draft: "Let's see if we have a problem."

    2nd draft: "Let\'s see if we have a problem."

    3rd draft: "Let\\'s see if we have a problem."

    4th draft: "Let\\\'s see if we have a problem."


    ...and so on.


    This seems to affect ONLY the private messaging editor. I tried it using two different themes and got the same bug, so it is not related to the theme in use. Normal post editing and previewing works OK. I can't find mention of this on SMF's site. I tried this on another site I installed 2.0 RC2 on, and did NOT get that error. :confused: I'm thinking it might be one of the plugins here.
     
  2. Pete

    Pete New Member

    I've noticed that if you quote more than one poat in a reply, the appearance of the text in the second quote (and probably third and beyond) gets all wonky.


    SMF will change the type face and the type size. I have to let the poat get poated and then go in by hand to fix the formatting afterwards.
     
  3. Rudy

    Rudy ♪♫♪♫♫♪♪♫♪♪ Staff Member

    Location:
    Home
    I actually don't care for the "nested" quoting, since the quote levels can often become too deep. It's a feature I can turn off or turn on, but can't adjust the number of levels.

    I know that SMF has an RC3 version out, but I tried a brand spanking new install of it elsewhere and it broke some of the themes. Not in too bad of a way, but like the bar that says "Quick Reply", the rounded end on the left is clipped off. Other than that, they say they did fix some issues in 2.0 RC3 over RC2, so maybe it would be worth it. I'd probably have to uninstall the plugins too...or reapply them.

    Tanx for the report! :roodywave:
     
  4. Pete

    Pete New Member

    Maybe I didn't describe the bug properly. :hmmm:


    I wasn't referring to nested quotes. I was talking about having more than one quote in the body of a reply, each one having its own set of delimiters.


    Now quit makin' excuses and go fix it! :mad:
     
  5. citizenkeith

    citizenkeith Bartender Staff Member

    Rudy,

    This probably has something to do with character encoding for your database. I know that bbPress recommends using UTF-8, and if you don't use that there will be backslashes near quotes and apostrophes.

    It might be as simple as changing an encoding setting in SMF's config file.
     
  6. Pete

    Pete New Member

    I believe Keith's right about this, -=Rudy=-.
    While you're at it, perhaps you could adjust the wheelbase, too. TIA! :roodytiphat:
     
  7. Rudy

    Rudy ♪♫♪♫♫♪♪♫♪♪ Staff Member

    Location:
    Home
    I have to check to see if I set the database up as UTF-8 or not, and see if the settings all match. I was probably 75% asleep when I set this up. :laugh:

    Thing is, slash handling should be taken care of by PHP. Something in the coding is off. There are a couple of options in PHP that deal with it (magic_quotes_gpc in php.ini is one such place to look. It almost sounds like when I mistakenly used "mysql_add_slashes()" and "mysql_strip_slashes()" in early programming of mine, vs. using the "mysql_escape_string()" function (which IIRC is NOT affected by the magic_quotes-gpc setting).

    And the slashes are showing up ONLY in the PM system, not in regular posts that I can tell. Go ahead--write a PM with some aspostrophes, preview it, preview it again, and watch the apostrophes stack up. That's definitely a PHP bug since the post has not been committed to the database yet.

    I have another site with a newer SMF on it--I need to check that. If my configuration is off here, and if it works on the other one...then maybe I can track that down.

    I'll have to see if I can repeat Pete's problem also. It's a BBCode function.

    One bug that I know of: sometimes if you are in an editing window and insert BBCode using one of the buttons, sometimes the opening and closing tags are swapped.

    I'm thinking an upgrade may have fixed these two bugs.

    I'll check this when I get a chance shortly. I'm catching up on homework on top of trying to get my computer back online so I can get to my "stuff". My WinXP borked on all the new hardware, so I'm starting fresh with a 64-bit Win7 for now.
     

Share This Page